BShapr and Carla

All your LV2 and LADSPA goodness and more.

Moderators: khz, MattKingUSA

User avatar
ZestieBumwhig
Established Member
Posts: 32
Joined: Fri May 20, 2016 4:56 pm

BShapr and Carla

Postby ZestieBumwhig » Wed Jan 08, 2020 9:15 pm

I've been enjoying BShapr (and its staccato sibling BSlizr). If you're wondering what those are, see here: https://www.linuxmusicians.com/viewtopic.php?t=19969.

But BShapr has an irksome quirk when I use it in Carla (though not in Ardour/Mixbus). Here, let me just paste in my comment from the github page. I've downloaded a newer version, which updated "the underlying widget TK," and sjaehn cannot reproduce my problem in this version. But I sure can! Have any of you encountered this? Or perhaps there's just something weird with my setup.
When I close the B.Shapr window in Carla, it continues working as expected. But when I re-open it (ie, to change some settings), all of the nodes seem to become inactive. I can grab any node in each scene, and that will "wake up" the curve, but until I do that, the effects are all on but in the initial state.

My envelopes are still there - I can see them - but I need to "wiggle" a node to get the computer to see the envelope. This is true from both "Rack" and "Patchbay" (in Carla).

Everything seems normal in Ardour.

I'm using Carla 2.0.90 in Debian 9.

Any insight is appreciated! Thanks.

sjaehn
Established Member
Posts: 21
Joined: Fri May 03, 2019 6:05 pm

Re: BShapr and Carla

Postby sjaehn » Fri Jan 10, 2020 3:21 pm

Thanks for informing that the problem still persists. I've some ideas for a possible cause, but I need further information. Please take a look at https://github.com/sjaehn/BShapr/issues/11 .


Return to “Plugins, Effects and Instruments”

Who is online

Users browsing this forum: No registered users and 3 guests