Behringer UMC1820 is working with Reaper and Linux Mint 19.1 and 19.2

Support & discussion regarding DAWs and MIDI sequencers.

Moderators: khz, MattKingUSA

waywayka
Posts: 1
Joined: Wed Oct 30, 2019 1:04 pm

Behringer UMC1820 is working with Reaper and Linux Mint 19.1 and 19.2

Postby waywayka » Sat Nov 30, 2019 9:52 am

This post is copied from another I had on the Linux Mint Forums. Might be useful to some:

Good news so far:

No stuttering on playback and record.
No interruptions when navigating, adding things, moving faders, etc.
A few plug-ins are being used with no interruptions.

Here's a list of what I would do to prepare Linux Mint, Reaper and UMC1820.

1. Read https://wiki.linuxaudio.org/wiki/system_configuration
Use the script provided to check your system.

2. Read https://forum.cockos.com/showthread.php?t=210390
(I haven't needed to do ALL of what's recommended, but the steps that follow are what I have done so far).

3. Edit the limits.conf file so that:
a) the user can change real time priority or 'rtprio' to 95
b} the user can change max locked memory 'memlock' to unlimited

How to edit the limits.conf file:
i) Navigate to 'etc' folder (found in File System)
ii) Right click on folder 'etc' and select Open As Administrator
iii) Open the limits.conf file
iv) Scroll to the bottom of the file and add these 2 lines before it reads "END OF FILE":

username - rtprio 95
username - memlock unlimited

*Newbies like me, be sure not to use a # or @ symbol beginning these two lines. The hash symbol prevents the line from working. It's quite easy to presume that the # is needed if you're not familiar with how the OS works. This is the mistake I made. The @ is used for groups.*

v) reboot computer

4. Change CPU governors to 'performance'
5. Change swappiness to 10

These are the other steps I took previously, and will eliminate them if the above was all I needed to do.

6. Disable bluetooth.
7. Disable Wifi and networking.
8. Disable any screen dimming

9. Now, in Reaper, select 'disable any power management'.
10. Increase block size to 64
11. Increase Rt to 50 (for starters)
12. Consider a lower screen resolution. (When I first had reaper working, I had a very low low screen resolution to things look bigger for my old eyes. Did this reduce CPU usage?)
13. Consider lowering the buffer (found this counter intuitive, but is a suggestion nonetheless).
14. Be sure to use a USB 2 port when connecting to the UMC1820. It is listed as a USB 2 device. Despite being backward compatible with USB 3, it may matter.
15. Disable Dropbox.

Return to “Recorders & Sequencers”

Who is online

Users browsing this forum: No registered users and 1 guest